US Server experiencing intermittent networking issues
Incident Report for Poppulo
Resolved
This incident has been resolved.
Posted Jun 10, 2021 - 08:58 BST
Investigating
We are currently experiencing some connection timeouts and slow response times with our US Admin, mobile and microsite services .

Our engineers are actively investigating the issue.

We apologize for any inconvenience this may cause and will keep you updated with progress towards a resolution.

-Poppulo Support
Posted Jun 09, 2021 - 11:24 BST
This incident affected: Poppulo Platform / Web Application and Email Microsites.