Service Delays on EU Server
Incident Report for Poppulo
Resolved
This issue has now been resolved. Please accept our apologies if you have been affected. If you require more information about this issue please get in touch.
Posted Mar 28, 2020 - 11:17 GMT
Monitoring
We are currently experiencing a delay in sends and reporting which is caused by increased traffic on the Poppulo Platform.

Due to the volume of sends currently in progress, it could take up to 10 minutes for your emails to start sending.

The open and click reporting metrics may not be up to date. It may take a few hours to reflect the accurate figures. As this appears to be an ongoing issue, our team is actively working to add more resources to resolve this issue.

Please accept our apologies for any inconvenience caused.
Posted Mar 27, 2020 - 16:06 GMT
This incident affected: Reporting & Analytics and Email Sending.