US Service Issue

Incident Report for Email and Feeds Status Page

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 21:28 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2025 - 21:10 GMT

Investigating

We are currently experiencing an issue that may be impacting your ability to fully utilize our services. With the access to the mobile/feeds product currently impacted.

Our Incident Response teams have been engaged and are looking into the issue.

Please accept our apologies for any inconvenience caused

Poppulo Support
Posted Oct 29, 2025 - 19:14 GMT
This incident affected: Mobile Publishing.