EU/US: Essential maintenance will be carried out on our EU and US servers Saturday 31st of January 4:30am to 6:30am GMT ( 30th/31st Jan 11:30pm -1:30am EST )
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 31, 2026 - 04:30 GMT
Scheduled
Essential maintenance will be carried out on our EU and US servers Saturday 31st of January 4:30am to 6:30am GMT ( 30th/31st Jan 11:30pm -1:30am EST )
During this time there will be delays in our Reporting Metrics
These updates are an essential part of our ongoing transition to a more advanced, cloud-based platform. This will bring long-term benefits including enhanced security, improved system stability, and greater scalability.
However, we understand any downtime can be disruptive, and we truly appreciate your patience.
Poppulo Support Team Reporting & Analytics
Posted Jan 22, 2026 - 14:56 GMT
This scheduled maintenance affected: Reporting & Analytics.