Admin Latency on the US server
Incident Report for Poppulo
Resolved
System latency and Sending issues have now been addressed

Reporting is now processing as expected without delays.

Please accept our apologies for any inconvenience caused.

Poppulo Support
Posted Aug 02, 2022 - 17:32 BST
Monitoring
System latency and Sending delays have now been addressed

Opens and click reporting metrics may not be up to date. It may take upto 1hr to reflect the accurate figures for open and clicks Please note your emails are delivering the reporting is just delayed in reflecting this.

Our Engineering teams are working to resolve the issue.

Please accept our apologies for any inconvenience caused.

Poppulo Support
Posted Aug 02, 2022 - 16:21 BST
Update
We are currently experiencing some system latency/slow down in the US Poppulo admin tool.

This latency is affecting Admin usage, Reporting and Sends.

Due to the volume of sends currently in progress it could take up to 30 minutes for your emails to start sending.

Opens and click reporting metrics may not be up to date. It may take upto 1hr to reflect the accurate figures for open and clicks and delivery reports . Please note your emails are delivering the reporting is just delayed in reflecting this. Our team is actively working to resolve the issue.

Our Engineering teams are working to resolve the issue.

Please accept our apologies for any inconvenience caused.

Poppulo Support
Posted Aug 02, 2022 - 15:21 BST
Update
We are currently experiencing some system latency/slow down in the US Poppulo admin tool.

This latency is affecting Admin usage, Reporting and Sends.

Due to the volume of sends currently in progress it could take up to 15 minutes for your emails to start sending.

Opens and click reporting metrics may not be up to date. It may take upto 1hr to reflect the accurate figures for open and clicks and delivery reports . Please note your emails are delivering the reporting is just delayed in reflecting this. Our team is actively working to resolve the issue.

Our Engineering teams are working to resolve the issue.

Please accept our apologies for any inconvenience caused.

Poppulo Support
Posted Aug 02, 2022 - 15:09 BST
Investigating
We are currently experiencing some system latency/slow down in the US Poppulo admin tool.

Our Engineering team is actively working to resolve the issue.

Please accept our apologies for any inconvenience caused.

Poppulo Support
Posted Aug 02, 2022 - 14:48 BST
This incident affected: Poppulo Platform / Web Application, Reporting & Analytics, and Email Sending.