Salesforce Service disruptions

Incident Report for Email and Feeds Status Page

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 16:25 BST

Monitoring

Salesforces is currently experiencing a service disruption that is affecting our Email and Support chat service.

If you require Support please reach out to us over the phone

Digital Signage (FWI)

INDIA: +918037244674
Intl: +13033133000

Email, Feeds & Mobile (Poppulo)
IRL: 1800806161
UK: 08000856388
US: 7814437600
INDIA: +918037244674
Intl.: +353212427277
Posted Sep 16, 2026 - 11:01 BST