EU and US Microsite Issues

Incident Report for Email and Feeds Status Page

Resolved

AWS have confirmed the Cloudfront issue has now been addressed : https://health.aws.amazon.com/health/status

All micosites are now accessible.
Posted Jul 16, 2026 - 13:37 BST

Update

A workaround has been implemented which has restored access to some customer microsites.

AWS is continue to investigate the issue on their end and implement a complete fix https://health.aws.amazon.com/health/status
Posted Jul 16, 2026 - 11:12 BST

Identified

AWS have confirmed that they are experiencing a global Cloudfront issue which is leading to the 504 errors on the microsites.

https://health.aws.amazon.com/health/status

AWS are investigating and the issue is being treated with the highest priority.
Posted Jul 16, 2026 - 09:51 BST

Investigating

We are currently experiencing an issue that may be impacting your ability to fully utilize our services. Microsites are currently experiencing issues. 

Our Incident Response teams have been engaged and are working toward a resolution.

Please accept our apologies for any inconvenience caused.

Poppulo Support
Posted Jul 16, 2026 - 09:23 BST
This incident affected: Email Microsites.