Service issue on US server

Incident Report for Email and Feeds Status Page

Resolved

This incident has been resolved.
Posted Aug 07, 2025 - 11:15 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 07, 2025 - 11:09 BST

Investigating

We are currently experiencing an issue that may be impacting your ability to fully utilize our services. With some login attempts failing

Our Incident Response teams have been engaged and have implemented a fix and are monitoring the results

Please accept our apologies for any inconvenience caused
Posted Aug 07, 2025 - 10:52 BST
This incident affected: Poppulo Platform / Web Application.