US Service Issue

Incident Report for Email and Feeds Status Page

Resolved

The incident has been resolved and microsites are working as expected again.
Posted Apr 14, 2025 - 11:24 BST

Monitoring

A fix has been implemented and microsites are loading correctly and we are continuing to monitor.
Posted Apr 14, 2025 - 11:13 BST

Identified

We have identified the issue and are working on a fix.
Posted Apr 14, 2025 - 11:09 BST

Update

We are currently experiencing an issue that may be impacting your ability to fully utilize our services.

There are issues with Microsites loading and you may be effected by this.
Posted Apr 14, 2025 - 10:55 BST

Investigating

We are currently investigating the issue
Posted Apr 14, 2025 - 10:44 BST
This incident affected: Poppulo Platform / Web Application and Email Microsites.