Scheduled maintenance for this evening has been postponed and will be rescheduled at a later date.
Regards
Poppulo Support
Posted Feb 20, 2026 - 08:15 GMT
Update
Scheduled maintenance for this evening has been postponed and will be rescheduled at a later date.
Regards
Poppulo Support
Posted Feb 20, 2026 - 08:14 GMT
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 16, 2026 - 09:45 GMT
Scheduled
Essential maintenance will be carried out on our US servers Friday/Saturday 20th/21st Feb 11:30pm -1:30am EST
We advise against sending during this period and there will be delays in our Reporting Metrics.
These updates are an essential part of our ongoing transition to a more advanced, cloud-based platform. This will bring long-term benefits including enhanced security, improved system stability, and greater scalability.
However, we understand any downtime can be disruptive, and we truly appreciate your patience.
Poppulo Support Team
Posted Feb 11, 2026 - 15:05 GMT
This scheduled maintenance affected: Poppulo Platform / Web Application, Reporting & Analytics, Email Microsites, Email Sending, Mobile App, and Mobile Publishing.