EU service Issue
Incident Report for Poppulo
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 14:40 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 25, 2024 - 13:54 BST
Update
We are currently experiencing an issue that may be impacting your ability to fully utilize our services. Reporting is currently delayed.

Our Incident Response teams have been engaged and are working toward a resolution.
Posted Apr 25, 2024 - 13:00 BST
Investigating
We are currently experiencing an issue that may be impacting your ability to fully utilize our services. Reporting and test sends are currently delayed. This does not affect live sends.

Our Incident Response teams have been engaged and are working toward a resolution.
Posted Apr 25, 2024 - 12:11 BST
This incident affected: Reporting & Analytics and Email Sending.