EU login down
Incident Report for Poppulo
Resolved
Access to the EU Poppulo Platform has now been restored

Apologies for all inconvenience caused.

Poppulo Support
Posted Oct 21, 2020 - 09:59 BST
Investigating
Access to the EU Poppulo Platform is currently down. If you are currently logged in you should continue to have access

Sends and microsites are unaffected

Our engineers are looking into this issue as their highest priority

Apologies for all inconvenience caused and we will keep you updated.

Poppulo Support
Posted Oct 21, 2020 - 09:45 BST
This incident affected: Poppulo Platform / Web Application.