EU login down
Incident Report for Poppulo
Resolved
Access to the EU Poppulo Platform has now been restored and deferred sends have delivered .

Apologies for all inconvenience caused.

Poppulo Support
Posted Oct 21, 2020 - 13:24 BST
Monitoring
Access to the EU Poppulo Platform has now been restored

You may see some deferred emails in your reports. Our system is currently processing the delivery of these mails and they will complete in time.

Apologies for all inconvenience caused.

Poppulo Support
Posted Oct 21, 2020 - 10:39 BST
This incident affected: Poppulo Platform / Web Application.