Delayed Test Sends and Reporting on the EU server
Incident Report for Poppulo
Resolved
This incident has been resolved.

Apologies for any inconvenience caused.

Poppulo Support
Posted Oct 08, 2021 - 09:03 BST
Investigating
We are currently experiencing some delays with Test Sends and Reporting

Due to the volume of test sends currently in progress it could take up to 30 minutes for your test emails to start sending. Live sends are not affected as they go through a separate queue.

The delivery, open and click reporting metrics may not be up to date. It may take upto an hour to reflect the accurate figures. (Please note emails are delivering it is the reporting that is delayed )

Our team is actively working to resolve the issue.

Please accept our apologies for any inconvenience caused.

Poppulo Support
Posted Oct 07, 2021 - 15:30 BST
This incident affected: Reporting & Analytics and Email Sending.