US site experiencing intermittent networking issues
Incident Report for Poppulo
Resolved
This incident has been resolved.
Posted Sep 14, 2020 - 21:13 BST
Update
We are continuing to investigate this issue.
Posted Sep 14, 2020 - 21:13 BST
Investigating
We are currently experiencing intermittent networking issues on our US site which can lead to access issues with the Poppulo platform.
Network engineers are actively investigating the issue. We will keep you updated with progress towards a resolution. We apologize for any inconvenience this may cause.

-Poppulo Support
Posted Sep 14, 2020 - 18:45 BST
This incident affected: Poppulo Platform / Web Application and Email Microsites.