Service delays on US server
Incident Report for Poppulo
Resolved
This incident has been resolved.
Posted Dec 06, 2022 - 17:28 GMT
Monitoring
Test sends are now processing as expected, and we are continuing to monitor.

Please accept our apologies for any inconvenience caused.

Poppulo Support
Posted Dec 06, 2022 - 17:16 GMT
Investigating
We are currently experiencing an issue that may be impacting your ability to fully utilize our services via Test sends. Live mailings process from a separate queue and are not affected

Our Incident Response teams have been engaged and are working toward a resolution

Please accept our apologies for any inconvenience caused.

Poppulo Support
Posted Dec 06, 2022 - 15:54 GMT
This incident affected: Email Sending.