US Admin Service Outage
Incident Report for Poppulo
Resolved
The US Poppulo Platform is now accessible.

Apologies for all inconvenience caused.

Poppulo Support
Posted Jun 13, 2022 - 09:59 BST
Investigating
Access to the US Poppulo Platform is currently down.

Our engineers are looking into this issue as their highest priority

Apologies for all inconvenience caused and we will keep you updated.

Poppulo Support
Posted Jun 13, 2022 - 09:49 BST
This incident affected: Poppulo Platform / Web Application.