Service Delays on the EU Server
Incident Report for Poppulo
Resolved
This incident has been resolved.
Posted Nov 15, 2022 - 17:28 GMT
Monitoring
Our engineers have implemented a fix and are currently monitoring the results.

Please accept our apologies for any inconvenience caused.

Poppulo Support
Posted Nov 15, 2022 - 16:17 GMT
Investigating
We are currently investigating service delays on the EU server causing delayed sends. Our team is actively working to resolve the issue.

Please accept our apologies for any inconvenience caused.

Poppulo Support
Posted Nov 15, 2022 - 15:29 GMT
This incident affected: Email Sending.